By Baltar
#6694
Hello all,

I am trying to use an SSC-32 from DFRobot to control servos. I have connected it to an arduino mega which sends serial commands to the servo controller.

I have connected the TX on the arduino to RX on the SSC-32, and connected ground to ground. A central LED labelled 'L' flashes every time the SSC-32 receives a message. I assume this means that it is receiving data.

I am powering the SSC-32 from the arduino, which works fine. The servos are powered separately. I have connected a battery (6V 2800mAh) to VS1 (and removed the VL = VS1 jumper).

For some reason, the servos will still not move no matter what I try. I have tried connecting the SSC-32 to my pc in order to use Lynxterm, but that didn't work either. In that case, the RX LED would flash rapidly as I moved the servo slider around, but the servo never moved. Also, when I had the SSC-32 connected to the pc, the 'L' LED would stay lit constantly.

I have tried the test code from both of the following sources:

[url=http://blog.martinperis.com/2011/05/libssc32-arduino-ssc32.html]http://blog.martinperis.com/2011/05/libssc32-arduino-ssc32.html[/url]

[url=http://robotics.nuvvo.com/lesson/7437-moving-servos-with-a-ssc-32-and-an-arduino]http://robotics.nuvvo.com/lesson/7437-moving-servos-with-a-ssc-32-and-an-arduino[/url]

Both seem to make sense, and both result in the 'L' LED on the SSC-32 flashing whenever a message is sent by the arduino, but the servos never move.

Can anyone help?

Thanks
By Lauren
#6695
Hello Baltar,

  I think you could try to make it work with PC first.
  Have you ever change the baud rate setting for the SSC-32 from the DFRobot? The default baud rate may be 115200(the DIP switch is ON). So you may need to set the right baud rate on PC software.
  If your LED would flash , it just means that the controller could get the bytes. But doesn't mean it could figure it out.

  Hope its useful~ ;)
By Hector
#6696
Also,


make sure that you have the right jumper settings for the USB connection. And the Baud rate is very important, make sure you have the correct settings for this.