I recently purchased a Blunt Beetle V1.0 and I am having trouble connecting it to my computer. I am following all the instructions in the tutorial (https://www.dfrobot.com/blog-283.html), but both Mac and PC computers are failing to recognize the device. I plug the Beetle in via USB and the device powers on showing an illuminated PWR light. When I go into the IDE and the Tools > Port menu, it does not appear to be showing any connection to the USB port. I have the Board option set to Arduino Uno, and the two settings in the serial monitor set correctly, yet the +++ command yields no result.

I also tried to update the firmware for the Beetle, and again followed the steps in the tutorial. After I download the firmware installer, I try to select the device in the com dropdown, but nothing is appearing.

How do I get my computer to recognize the Beetle when it is plugged in?

I purchased two Bluno v2.0 and running into same issue with both of them. Tried multiple computers. DF Robot Arduino is detected and runs fine on these same computers.

It is disconcerting that a highly priced product like this is of such poor quality. What QA is done on each module being shipped? Are they even tested for proper boot up?
Hello, I am trying to connect with 5 Beetle BLE v1.1 boards and I am having the same exact issue. Were you able to find the solution to this? I have tried the advice above, including using a USB2 port.