Bluetooth Issue with Beetle V1.1 SKU DFR0282:
I've ordered 3 of Beetle V1.1 SKU DFR0282 chips and all have the same issues. It does not show as a bluetooth device. I've tried with Window PC, Android Phone, MacBook Pro, and iPhone. None of these devices picked up the BLE signal. I cannot get the bluetooth to recognize; it simple does not show.

What I Tried:
The chip has power. It is set as Arduino Leonardo in Arduino IDE. The chip is recognized using the Micro USB port. I can use Arduino IDE and sucessfully upload code to it using a Micro USB cable and the code runs just fine but it still won't get recognized as bluetooth. I even tried to use the Bluno firmware downloader on Mac and PC to try to update the firmware (I've tried: UBL2SBL.bin, BLUnoV1.6_ENC.bin, SBL_BlelinkV1.97.bin, SBL_BlelinkV1.9, SBL_BlelinkV1.94, SBL_BleMega2560V1.97.bin, SBL_BlunoV1.97.bin, SBL_BlunoV1.84-170706, etc.) and all I get is either "Download Stop", "Download TimeOut", or "Cannot Open Serial". Also, I cannot enter AT command mode. I type in AT commands in Arduino IDE Serial Monitor and I get no return text.

My computer of choice is my MacBook Pro running MacOS Mojave 10.14.4.

Here are some question in which I cannot find the answer to anywhere:
  • How can I enter AT command mode using Arduino IDE Serial Monitor with this specific chip? (all other tutorials like the Bluno Beetle V1.0 do not work)
    How can I update the firmware if the firmware downloader is not working on Windows or Mac?
    I am using this chip alone, could this be an issue? Do I need another chip for it to work (like an Arduino Uno)?

Does this chip even work anymore? Is it depreciated somehow? I've been trying to get this to work for 3 days now. :cry: