#4638
Hello
I am struggling to get the two Bluno's I have to be able to program the peripheral Bluno. I get the error:

avrdude: stk500_getsync(): not in sync: resp=0x00

I've tried all AT commands, changed all possible settings and upgraded the firmware, no luck.

Any help would be greatly appreciated.

Thanks!
#4640
Hello bikeben,

Yeah, like what visualxl said, the link LEDs should be turn on when they are connecting.
Are you using the newest firmware v1.8E?

Is there anything occupying the "RX" and "TX"? Like some shield is plugged on the bluno.
Generally, STK500...0x00 means the Serial port has been using, or sometimes it has been occupied by other device like wireless module.
#4642
Really?

Are you using PERIPHERAL to upload the sketch to CENTRAL, when you get this ERROR?

Because only CENTRAL could upload the sketch to PERIPHERAL one, the CENTRAL usb port has high permission to access CC2540 bluetooth communication. So for the wireless programming, we often plug CENTRAL to the PC USB port.

Hey bikeben,
Could you exchange two device? using CENTRAL device to upload sketch to the PerIPHERAL one?
#4643
err... Grey,

What I meant was that uploading the sketch to a CENTRAL/PERIPHERAL though a USB cable when both of them are connected via BLE link.

BLUNO central can upload a sketch to BLUNO peripheral wirelessly?? How is that possible?
#4644
Of course, yes

You could have a try. 8) It is very easy. like you could use ble link to make a wireless programming. it is same in theory.

I know what your mean, yes, if you want to download the sketch via usb, it requires cut connection first.