By mrother
#9647
Hi everybody,

We’ve a issue with one of our Vortexes:
We use WhenDo on an iPad and when we try to upload a program, it says after pressing the download button “Device connected”.
But when we try to upload, it gives an error message like “system not ready” or something like this. When we tap the “search” (lens) button, it does not show the Vortex.
But in the Bluetooth settings on the iPad it shows the vortex as connected.
I’ve read about this issue here and understood that it should not be connected via the iPad BT settings (as for the password issue).
But I already tried serveral times to turn VT and iPad BT off, waited some minutes and turned both on again, but still WhenDo shows “device connected” but shows the error when I try to upload.
I even rebooted the iPad and only opened WhenDo, put together a tiny program (turn eyes on/off, nothing else) and turned on VT, then tried to upload but without success.

How can we solve that?

Thanks in advantage and greetings
Mike
By Leff
#9652
To this problem, according to your description, sorry I am not sure if you have hit on the paired vortex in the BT setting panel to disconnect them before you use WhenDo for connection?

If you did disconnect them in the BT setting, then could you use your Android/iPhone to test if your phone can connect it AUTOMATICALLY? (sure, your phone should either not be connected with Vortex through BT settinig panel.)
  • If they can, it should be no problem, please try again.
  • If failed on phone, then it should be the bluetooth service problem, you can ask for a return by going to return page or fix it by yourself if you have a CC debugger.

Another possible reason is that the BT service is good, while the bootloader was lost. The phenomenon is that Vortex can be connected, but can not be programmed, nor can be update firmware by phone.

In this situation, to confirm the problem, you could install the software Arduino IDE,, then use a USB to connect VT with your PC, then upload a example code like "blink" to see if it can be uploaded.
By mrother
#9686
Hello Leff,

thanks for your kind advisory.
I tried again and again, rebooted iPad, took batteries out of Vortex and several times tried to un-bind it via the iPad's BT settings page.
Didn't realize after which attempt but finally got it to download programs.
Intresting is that WhenDo says "Device connected" but if I tap on the magnifying glass symbol in the upload pop up window, it does never find the Vortex.
But I don't worry about since program download is working.
Today I found a new issue, but I will open a new thread for it as it is a totally different topic and needs a proper subject line so other users could find it and benefit from answers I may get. (I'm a technical supporter by work, so I know about the importance of not asking several questions under one subject line ;-)

Thanks again and kind regards
Mike
By Leff
#9695
Hi Mike,
:)
Thanks for your feedback and your consideration.

It is normal that VT could not be found once WhenDo shows "connected.", if you disconnected it, and hit the button to search VTs, you could see it on the list. (I didn't use WhenDo for a while, not sure if it has been updated or not.)

Any question/feedbacks are welcome.