Page 1 of 1

Firmware with IIS for FireBeetle ESP32 + Camera-Audio Media Board covers with uPyCraft

Unread postPosted:Thu Apr 16, 2020 9:35 am
by ricogte
Hello,

I have the DFRobot FireBeetle board-ESP32 V4.0 + FireBeetle covers Camera-Audio Media Board V1.0.
I work with uPyCraftV1.1. I burn the board with the "official" micropython firmware: http://micropython.org/download/esp32/
The board works and dialogs well, but the IIS from MACHINE library does not exist.

This library is essential to operate the covers, in accordance with the instructions of DFRobots: https://dfrobot.gitbooks.io/upycraft_en ... ot.py.html

I found the DFRobot github: https://github.com/DFRobot/uPyCraft/
There are firmware. I tested mpy-fw-esp32-20171124.bin at mpy-fw-esp32-20170406.bin. After burning the board, it is impossible to interact with the board :(

Do you have firmware, with IIS library, that works with the FireBeetle ESP32 borad + Camera-Audio Media Board covers?

Thank you

Re: Firmware with IIS for FireBeetle ESP32 + Camera-Audio Media Board covers with uPyCraft

Unread postPosted:Mon Apr 20, 2020 2:16 am
by nana.wang
Hi, thank you for your support and contact.
We are checking it and will feed you back ASAP.

Re: Firmware with IIS for FireBeetle ESP32 + Camera-Audio Media Board covers with uPyCraft

Unread postPosted:Tue Apr 28, 2020 5:24 am
by nana.wang
Hi, we have tested it with uPyCraft_V1.0.exe
And the firmware version is mpy-fw-esp32-20171124.bin with examples_V1.9.zip, it can work via IIS.
You can download it via https://github.com/DFRobot/uPyCraft

Re: Firmware with IIS for FireBeetle ESP32 + Camera-Audio Media Board covers with uPyCraft

Unread postPosted:Wed Apr 29, 2020 7:21 am
by ricogte
Hi there,

It's surprising, because it doesn't work for me:
So, I'm using uPyCraft V1.0.exe
DFRobot FireBeetle board-ESP32 V4.0 + FireBeetle covers Camera-Audio Media Board V1.0 on COM12
board esp32
burn_addr 0x1000
erase_flash yes
Choose the firmware / Users / mpy-fw-esp32-20171124.bin

It seems to erase and burn the board correctly.
But when I want to connect to it, it says "open serial error, please try again".

NB: I can connect classic esp32 and esp8266 without problem.

So I also tried using the esp tools (I think it should work too?) In a terminal:
esptool --chip esp32 write_flash -z 0x1000 mpy-fw-esp32-20171124.bin
That seems correct:
"...
Hash of data verified.
Leaving ...
Hard resetting via RTS pin ... "

If I try to communicate with my board with Putty for example, I have a message that appears every second:
"rst: 0x10 (RTCWDT_RTC_RESET), boot: 0x1f (SPI_FAST_FLASH_BOOT)
flash read err, 1000
ets_main.c 371
ets Jun 8 2016 00:22:57
"
Without having control :(

Do you have any idea of ​​my problem?
Thank you.

Re: Firmware with IIS for FireBeetle ESP32 + Camera-Audio Media Board covers with uPyCraft

Unread postPosted:Wed May 06, 2020 5:28 am
by nana.wang
Hi, please try modifying the burn_addr 0x1000 to burn_addr 0x0000.
It will work.

Re: Firmware with IIS for FireBeetle ESP32 + Camera-Audio Media Board covers with uPyCraft

Unread postPosted:Sat May 09, 2020 8:12 am
by ricogte
It works. Thank you.
(It's surprising, I thought I tried).
So, I don't understand why to use this address 0x000, whereas for all the other boards, I used the address 0x1000.
Can you explain it to me?
Thanks again.

Re: Firmware with IIS for FireBeetle ESP32 + Camera-Audio Media Board covers with uPyCraft

Unread postPosted:Sat May 09, 2020 8:22 am
by ricogte
The snapshot.py example works for me, I can read the photo1.bmp file on the SD card.
For the camera.py example, I can successfully connect to WiFi. The program gives me an IP number: 192.168.0.32. This is the one I indicate in camera.exe. I press start, but the screen of camera.exe remains black.
Here is the return of my board:

Ready to download this file,please wait!
.........
download ok
exec(open('camera.py').read(),globals())
I (961804) wifi: n:13 0, o:13 0, ap:255 255, sta:13 0, prof:1
I (961804) wifi: state: init -> auth (b0)
I (961814) wifi: state: auth -> assoc (0)
I (961894) wifi: state: assoc -> run (10)
I (962294) wifi: connected with freeboxrico, channel 13
[0;32mI (962294) wifi: event 4 [0m
[0;32mI (964964) event: ip: 192.168.0.32, mask: 255.255.255.0, gw: 192.168.0.254 [0m
[0;32mI (964964) wifi: GOT_IP [0m
Allocating frame buffer (38400 bytes)
Init done
Camera Ready
I (971894) wifi: pm start, type:0

I (1032894) wifi: bcn_timout,ap_probe_send_start
I (1035394) wifi: ap_probe_send over, resett wifi status to disassoc
I (1035394) wifi: state: run -> init (1)
I (1035394) wifi: n:13 0, o:13 0, ap:255 255, sta:13 0, prof:1
I (1035404) wifi: pm stop, total sleep time: 0/63504333

Do you have an idea?
thanks

Re: Firmware with IIS for FireBeetle ESP32 + Camera-Audio Media Board covers with uPyCraft

Unread postPosted:Tue May 12, 2020 5:39 am
by nana.wang
Hi,
1. Please make sure that the motherboard is under wifi coverage and that the signal is strong enough. If the signal is not good enough, it will cause an unstable connection.
2. If the burn program is still not okay, please try the method as below
1) Disconnect and reconnect and re-run the program.
2) Re-download the program and run it.
3) Re-power the motherboard, and run the program after the connection.
4) Reburn the firmware, download the program and run it.

Once the program runs normal, please click and donload the software tool in need in wiki.
Then click start after inputting the maincontrol IP No.