HuskyLens is an easy-to-use AI machine vision sensor. It is equipped with multiple functions, such as face recognition, object tracking, object recognition, line tracking, color recognition, and tag(QR code) recognition.

I bought a HuskyLens, received one week ago, tried to update its firmware from v4.35(shown on HuskyLens General Setting) to v4.7-Stable yesterday.

I followed ... 6#target_6 and ... 6#target_7,
downloaded related drivers from ... cp-drivers

Unfortunately, I installed corresponding drivers for Win7/Win10/Ubuntu 18.04/Mac OS(update OS), all cannot find the device?!
Ubuntu/Mac : dmesg grep | tty, nothing responded?!
Windows 7/10: "Ports(COM&LPT)" not shown on Device Manager list.
("Device" column shows nothing on K-Flash.exe)

On the other hand, I tried to connect it with UNO and executed sample code, it works!
I am confused! :shock:

How can I solve firmware update issue?
Thank you!
By yuyouliang2012

Do you mean that you use the microUSB cable to connect the UNO board to the PC, you can see the COM port of the UNO board listed in the device manager, but when you use this microUSB cable to connect HuksyLens to the PC, you can not see any COM port in the device manager?
When you use this microUSB cable, does the HuskyLens work fine? Will it restart? Are all functions normal?
Please try plugging and unplugging multiple times to see if any COM port appears.

Please try according to the above steps first. If it still doesn't work, please contact the technical support mailbox: [email protected]