Easy IoT is a simplest IoT Solution presented by DFRobot
I am also having a problem to get my SIM7000C Shield NB-IoT LTE GPRS GPS module working.

From what I have noticed, unless I add a secondary power supply , via the micro USB connector, the ON red LED does not turn on.

This applies when the shield is supported by an UNO or a MEGA Arduino board.

I tried using a Raspberry 5v, 3 amp, power supply for the secondary supply, connected via the micro USB.
This caused the ON LED to light up, but it was not very bright and to also seemed to fade in and out a bit.

I have noted that the specifications require a 7 to 12 v DC supply.

I have 12v power supply and the ability to make a connection to the shield.

1) Is there any way to connect an external power supply to the shield apart from the micro USB connector?
2) Are any of the pins designed to allow an external power supply to be connected to the shield (i.e. the UART 5v pin)?
3) Can you provide a photograph or video clip of a working example of an Arduino with the SIM7000 shield connected and working?
4) Do you have and advice on how to connect the external power supply to the shield?

Dear Chen,
I have 9 v battery installed at my nb-iot sim-7000E!
But again i have it stuck on "TURN ON SIM-7000"
I am with cyta at a testbed nb-iot for Cyta that is working with other nb devices.
But i believe for sim-7000e to turn on network is not a factor? OR is it?
If the test is successfull nicosia will be full of dfrobot sim7000e . I am the guy that will make the city clever :)
Please check asap.
With my very best regards
I have the same problem! I power enough the shield with the appropriate volts...The shield is brand new..The net light blinks as expected but the module doesn't turn on(on the serial monitor it does nothing)..It's essential to mention that the shield worked fine for a while then just one day it didn't turned on again.. Can you help me ??What can I do.. Why this is happening?
I'm experiencing the same thing, it's quite annoying.

I have the shield powered through the UNO with a 12v/2.5A supply and it was working fine for about an hour and now it's just stuck forever at the turnON stage.

It sounds like this board is maybe prone to this ?

If anyone has a solution that would be great - otherwise I feel like I've just wasted a bunch of money.
Another turn on problem. I think I have tried/addressed all the suggestions in this post,
I used the examples ; DFRobot_SIM7000_ATtest and DFRobot_SIM7000_HTTP that came straight from https://github.com/DFRobot DF DFRobot_SIM7000-master. The same problem happens with both examples.
Shield ; SIM7000E Arduino NB-IoT/LTE/GPRS/GPS Expansion Shield DFR0572
Board; Unbranded Uno clone
Powered; 11.1v Lipo battery connected to GND and VIN of Shield & Uno
Alternatively and still unsuccessfully, a large 12V sealed lead acid battery
Monitor: Serial monitor of Arduino IDE 1.8.9
Serial switch is set to Tx>D8; Rx > D7
Software; Downloaded DFRobot_SIM-master and DFRobot_SIM7000-master from https://github.com/DFRobot on 7/9/2019
Unzipped using Arduino IDE “add Zip library”
When uploaded and the output checked on the Serial monitor, the code never reaches the line “Serial.println("Turn ON !");” Same result for both code examples
I tried changing the 20ms to 3000ms as suggested in 1 reply to this post.
Using debug text I have found that library file “DFRobot_SIM7000.cpp” has a function “TurnON” within that function the code is hanging/trapped in this while loop . Library only modified by addition of the labelled insertions to generate debug text.
Serial.println(F("The first While(1) of TurnON fnxn has commenced")); //VN insertion
i = 6;
baudrate = 19200;
Serial.println(F("in While i")); //VN insertion
return true;
Serial.println(F("in if(check_send_cmd ")); //VN insertion **worked to here 6 times then back to TurnOn fnxn has commenced
i-- }
Happy to add any code that would be helpful, just thought this post was pretty big already.
Vere Nicolson