By iram
I purchased a measurement sensor SEN0153 Ultrasonic,

as a test, i connected the VCC to a DC power supply 3.5V, and connected the tx/rx to USB connector(TTL) in my computer. also i merged the GND of the USB and the Power supply

then, i used a serial terminal program: Real Term. i set the baud rate to 19200. as it said in the datasheet.
i tried to send the sequence 0x55 0xaa 0x11 0x00 0x02 0x12 as numbers
and 55 AA 11 00 02 12 as ASCII
but i didn't receive any response

is there anything i'm doing wrong?

Ira Murachver
Computer Engineer
Spetrotec ltd
Last edited by iram on Thu Apr 23, 2020 8:06 am, edited 1 time in total.
#41581 wrote:
Thu Apr 23, 2020 2:15 am
Hi Ira,
Thank you for your support and contact.
Please try sending the sequence 55 AA 11 00 02 12 as HEX.
Thank you for your quick response.
i tried to send this sequence as hex, but still there is no response. what can be wrong?
is the blue LED should be OFF all the time? it's only blinks once when i connect it to DC voltage.
should i connect a pull up resistor maybe?
is there any timeout after i connect it to voltage for me to send the commands?
Hi, thank you for your feedback.
Please try the steps as follows:
1. It is normal to flash the lamp once powered.
2. Please ensure the communication wire is connected rightly.
3. Please ensure the sensor parameters are in default status. If you're not sure, refer to the method on WIKI to restore the default settings。
4. When communication is normal, the LED on the board flashes once every time the sensor receives the correct data. If the LED does not respond during communication, which means the communication was not successful.

If all checked are alright, but the sensor still cannot work. Is it convenient for you to get remote assist via TeamViewer?
i couldn't find anywhere in wiki steps for restore default settings.
i will be happy to receive assist like this
please tell me your e-mail address that i could send my details there