#9302
I am unable to upload sketches into SFRobot Arduino Pro-Mini. I have three of them, all exhibiting the same problem.
I don't get the traditional blink indicating the boot loader is installed.
I have tried to install a new bootloader using the "Arduino as ISP" with a known working Pro-mini, but with no luck.

What is wrong with these boards ????
#9310
Thanks for the reply; it's the 16MHz 5v one, DFR0159.

I've seen a lot of chatter on the Internet with regard to problems these third party xxxRobot board. These DFRobot devices were purchased for a professional application. The Inland devices I bought for personal use were half the price and have worked perfectly.
#9337
Leff,

I've tried reprogramming using both another known working Arduino Pro Mini ("Arduino as ISP") and a known working classic Arduino ("Arduino as ISP"), using instructions on the Arduino website.

I do have an Inland FTDI USB to serial adaptor which has the 6-pin header, and which I understand should also be able to do the job, but I don't have definitive instructions on how to use that.
#9340
Hi j.opificius,

Take an Arduino controller as an ISP programmer could do the job to flash the bootloader, it often used to save a defective arduino board lost bootloader. But to program a sketch, it is very complex that I haven't tried yet, but it can as I know. For more info, here I wrote a post which could be found in Good to know, Arduino common problem (updating).

And as long as you have that programmer, you can do it easily then. Plz contact the seller or find how to online for yours. Also you could take ours as a reference. They should be very similar. :)

Plz see my next post about how to use the USB adapter.
#9341
How to use a USB adapter to program an Arduino card without serial chip, like the DFRduino Pro Mini V1.3(16M5V328), DFR0159 we used here as an example?

Here i will show how to use that three USB-TTL adapters in our store, they are:
  1. Xbee USB adapter (FTDI ready) DFR0050 (It is the easiest one I recomand)
  2. FTDI Basic Breakout 3.3/5V (Arduino Compatible) DFR0065 (This one is similar to DFR0164, the third one. I will only show how to use DFR0065 later)
  3. USB Serial Light Adapter - Atmega8U2 (Arduino Compatible), DFR0164


STEPS

  1. Connection diagram for DFR0050

    • GND-GND
    • Vcc-Vcc
    • Rx-Tx
    • Tx-Rx
    • RST-RST

    (85.5 KiB) Downloaded 731 times

  2. Connection diagram for DFR0065 & DFR0164

    NOTE: the jumper cap should be located on 5V, choose 3.3V if yours board is 3.3V compatible.

    • GND - GND
    • Vcc - Vcc
    • Rx - Rx, this is right, not a typo. As you could find the lable (Tx, Rx) on PCB is adversed with its PCB drawing for both DFR0065 SCH & DFR0164 SCH, some guy has suggested to change it to be consistent. :roll:
    • Tx - Tx
    • DTR (FTDI)- Capacitor, 100nF - RST (controller), the capacitor is a MUST, and 100nF is suggested, I tested with 200nF, 20uF, also work.

    DFR0065
    (88.17 KiB) Downloaded 731 times


    DFR0164
    (84.18 KiB) Downloaded 731 times

After you hook them up like above, you could upload likeuploading a sketch to arduino UNO by choosing the "board", "Com Port" and cliking the Upload. here for DFRduino Pro Mini V1.3(16M5V328), DFR0159

(25.8 KiB) Downloaded 731 times
#9355
Thank you for all this work, Leff, but I fear you have missed the point.

NONE of the Pro Micro boards will accept a program using either of my two FTDI USB to Serial adapters.

NONE of the boards will accept reprogramming of a boot loader either.

All 3 are brand new boards from DFRobot, yet none of them accept code. They seem like they are trying (flashing lights), but programming fails.

I have two Pro Minis from other manufacturers, that DO accept programs, also a Due and a Mega 2560 from other manufacturers. All of them accept programs.

The three Pro Micros from DFRobot will not accept programs or a new bootloader.

So again, what do I do with these DFRobot boards? Is there something special I need to do to program them with a bootloader? Your instructions above are for loading sketches, not bootloaders.

Thanks!