I've been experimenting with the motor shield and have run into a problem. I was testing the board without any motors, making a test program to run the motors, adjust the speed, and turn them on and off. This was all done with the jumpers set to VIN. Everything seems to work as expected, with the LEDs turning red/green as commanded.

I then hooked up an external power supply to the motor shield and measuring at the terminal screws gave me  a little over 9 volts. I then moved the jumpers from VIN to PWRIN, but the voltage at the terminals dropped to around 0.7 volts.

The program also does not run, whether hooked up to the USB or not - the LEDs don't seem to light up.

I assume this is not normal. During these tests, no motors were connected. Can anyone offer any help? My background is software, not electronics, so I'm a little out of my element when things don't work electrically.


Hi Fred,

We sell a couple of motor shields. Could you give me the SKU for the one you are using?

Have you removed the power source and tried running the program through USB only (as you originally set it up)?

Its better to connect the motors as this will give you a load to test, and will not stress the motor controller.
Sorry, the board SKU is DRI0009, the 2 A motor shield. Its mounted on the DFRobot Arduino Uno USB SMD (SKU DFR0122).

I can connect/disconnect the external power and run off the USB again with no problems. The board seems to work OK, just not off external power.

I had tested with the motors before, but got no reaction from them. That's why I switched to using the Arduino power to determine if the shield worked at all. I don't want to work with the motors with the Arduino power (VIN) as I understand I could overwork the Arduino power. I thought perhaps the motors were affecting the voltage, so I left them off to check whether they affected the voltage. Voltage is fine at the terminal screws until I install the jumpers for PWRIN.

One more thing I notice is that the red LEDs are significantly brighter than the green LEDs at the same speed setting (this is when running off VIN, no motors). Not sure if this is normal or not - at this point it's just an observation.

Hi Fred,

Did you notice the warning in the wiki [quote][font=Arial][size=13px]NOTE: When the motor shield is powered by external power source, make sure the external power source and Arduino have the same GND.[/size][/font][/quote]

Try adding a jumper wire between the (-) battery terminal and a "GND" socket on the shield. This might get it working, if that doesn't work let me know.
I saw the notice, but another thread here seemed to indicate that the grounds on this shield are already connected - not sure if I misunderstood.

I tried connecting the (-) terminal to GND (beside AREF) but there was no change.

I am using a wall-wart type adapter. I had one with 6V/200 mA rating, and another with 9V/400 mA. Neither provides sufficient voltage when connected. I suspected that the 6V adapter would not provide enough juice but it doesn't seem to make a difference. The 9V supply seemed to get hotter than I'd expect it should.

Hi Fred,

Ok, you don't need to place a jumper wire between the grounds, you do however need to supply power to the arduino from a separate source, just make sure you have set the PWRIN jumpers when you connect two power sources. Give the Arduino a few seconds to start up and it should get your motors running. I tried it by supplying USB power to the Arduino and a 9V wallwart to the shield PWRIN Terminals.
Give it a go, and let me know your results.

I have been powering the Arduino from the USB on my computer and running my test program. The test program seems to run - I have the debug LED (pin 13) flashing to let me know the Uno is running, and I get responses from the serial monitor - just no response from the motor shield when connected to PWRIN. I do get a response from the motor shield when I connect to VIN.

I'm thinking there is something wrong with the power on the board. I did note that the power connector is a bit slanted on the board, but I didn't think it would make a difference. Pictures attached so you can see.

I've got a friend with the same model Uno and board. I'll try testing with his setup (he is able to run a motor off external power) to make sure none of the other components are having an impact, but I'm really thinking there is something with the board...

OK, I had some success using the motor and power supply from my friend. It appears that my power supply must suck. My friends 12V/780 mA wall wart will run his motor, while mine does not.

Still, the power supply would run his motor connected straight, so it appears that there is enough current for that.

Hector, what power supply were you using? Is it regulated? What is the current rating on it?

I can't say I understand what is going on as the board does not seem to even run with no loads attached. The board seems to be working with the right power supply though, so I'm happy about that.

The supplies I've been trying are salvaged from other electronics (I don't recall what). I'll have to look for a better one.

Thanks for your feedback!