#2222
Hello, I`ve recently purchased a BluetoothBee from http://www.dfrobot.com/index.php?route=product/product&path=45&product_id=193. It`s default baud rate is 9600 bps and if I want to change it I have to put the module into AT mode and execute some AT commands as stated in http://www.dfrobot.com/wiki/index.php?title=BLUETOOH_BEE_(SKU:TEL0023). I`ve tried connecting to the bee with a terminal program and entering AT -> AT+BAUD8 and also tried to write these command directly to the COM1 port on the device using SerialPort class, but both these approaches failed.
What am I doing wrong and is it possibe to reconfigure the bluetooth bee using Fez Domino? The bluetooth module is working and I`m able to send and receive data on the Domino but only if it`s SerialPort is created with 9600bps.
#2223
Hi Soth,


How are you connecting the bee to your PC? Are you using a USB xbee converter?


What terminal program are you using?


You are placing the on-board switch to AT mode, yes?


I'm not sure if you can program it from your FEZ.


Ok, You can use the Arduino serial terminal. The default "AT Mode" baud rate is 38400 and you need to set "both NL & CR" setting next to the baud rate. Now you should be able to make the necessary changes.
If the first time you try it returns an "error(0)" just try again.





#2224
I`m using putty. Yes I use the switch to set the AT mode, on the Bluetooth Bee the green light turns on when I connect to it with putty through the virtual COM port, which was created by Windows for the Bluetooth_V3 device. I send AT command but get nothing in response from the device.
#2225
[quote]
Ok, You can use the Arduino serial terminal. The default "AT Mode" baud rate is 38400 and you need to set "both NL & CR" setting next to the baud rate. Now you should be able to make the necessary changes. If the first time you try it returns an "error(0)" just try again.
[/quote]

Did you try the 38400 Baud rate? Did you try it from the Arduino terminal? I couldn't get Putty to work for some reason.