By marphil
Hey everybody! Looking for some basic help.

I've just bought a new RoMeo 1.1 from a reseller here in Australia :). But I can't program it using the Arduino IDE.  :(  Board functions OK with USB cable plugged in - I get power LED and standard blink LED, so assume board OK.

I just loaded the Blink example in IDE, modified it to 1000ms on, 100ms off, (to look different on board) and attempted to load it to RoMeo. Compiles fine but doesn't load to RoMeo. I tried exactly same with a Arduino clone and it works so nothing apparently wrong with IDE etc.

I've captured the compile messages for both cases in the IDE and the RoMeo load produces a apparent fail in the avrdude section: saying "stk500_getsync(): not in sync: resp=0x00" see below

w/ RoMeo
avrdude: Version 5.11, compiled on Sep  2 2011 at 19:38:36
        Copyright (c) 2000-2005 Brian Dean, [url=][/url]
        Copyright (c) 2007-2009 Joerg Wunsch

        System wide configuration file is "E:\Program Files (x86)\Arduino IDE\arduino-1.0.1\hardware/tools/avr/etc/avrdude.conf"

        Using Port                    : \\.\COM1
        Using Programmer              : arduino
        Overriding Baud Rate          : 115200
avrdude: Send: 0 [30]  [20]
avrdude: Send: 0 [30]  [20]
avrdude: Send: 0 [30]  [20]
avrdude: Recv:
avrdude: stk500_getsync(): not in sync: resp=0x00

avrdude done.  Thank you.

Same section in the clone case, goes on to show some Recv data.

w/clone .....

avrdude: Send: 0 [30]  [20]
avrdude: Send: 0 [30]  [20]
avrdude: Send: 0 [30]  [20]
avrdude: Recv: . [14]
avrdude: Recv: . [10]
        AVR Part                      : ATMEGA328P

I'm new to the IDE. The clone works on COM4, the RoMeo seems to self select COM 1 (the only another COM displays is COM 6 - I tried it and it just hung on load.)

Any clues people? Does anybody know what "stk500_getsync(): not in sync: resp=0x00" means?
thanks in advance  martin   
By Hector
Hi Martin,

For the new Romeo what board are you selecting in the IDE? I believe you should be selecting "Arduino UNO" and not 328p.

That error is a generic error and not very helpful. It could be a variety of things.
1. Board is bad.
2. USB cable is bad. Try a different USB cable, and USB port. Even a different PC. Just to make sure. Even if the cable works with another Arduino.
3. Board has lost bootloader info. Can be fixed, but you need a [url=]programmer[/url].

Also, do you have anything plugged into the Romeo (other than USB)?
If so, unplug everything else.

Don't worry if the board is bad, just contact the distributor for a replacement. Try to trouble shoot the board first, if you still find that you can not get it working, ask the distributor for a replacement. If you have any troubles with the process just email us at Techsupport AT dfrobot DOT com.

Hey there.

I have a similar problem with Romeo. I have an Arduino UNO board and Romeo and use the Arduino 1.0 software to compile the codes.
Well, when I plug the UNO board, it appears "COM5" on the Serial Port list in the menu, and everything works fine. Though, when I plug Romeo (with the same USB cable, btw), this port is not appearing in the menu.
I didn't install any drivers for the Romeo board, and Im afraid that may be the problem. If someone knows where I can find it, maybe that's the problem.

By Hector
Hi Reddy,

I don't believe you need to install any additional drivers for the board. Is your Romeo one of the newer ones? with the red,blue,green headers?

I would still try:

A different cable (just in case)
A different USB port
A different PC.

You might want to try closing and re-opening the IDE, sometimes the IDE won't recognize the board, until it has been re-started.

If you can not get your Romeo working please e-mail me at Techsupport AT DFRobot DOT com.

By marphil
Hi Hector,
I fixed my problem. You're that message is a generic message,  basically saying board and PC not communicating. I googled the message and got lots of hits. for me it turns out I didn't load a driver for the RoMeo. I thought it would just work because I had the Arduino clone working fine. But thet turned out to have a proprietary driver from the manufacturer. Anyhow followed the process to load driver - picked UNO driver first but that didn't work, I needed the UNO REV 3 driver. Now works fine  :). so thanks for help.

By the by, Reddy, my Romeo is one of the newer ones (red blue green headers) and it needed a driver. as above you need the UNO Rev 3 driver.
By Hector

Glad you got yours working, and thanks for the heads up. Its hard for us to notice these problems, as most of our PCs at the office are all loaded up with the necessary drivers.