#29964
I finally bought the Titan case for my LattePanda Alpha and was excited to use it. I installed the case and tested it out. Everything worked fine.

One day later (today, July 4, 2019) the Alpha does not turn on.

At first, I the red led lit up and the blue one was blinking, but it would not boot.

I thought the power supply might be bad, so i tried another power supply with a different USB-C cable. There were no led lights at all.

Going back to the original power supply, it did boot one time only.

After that, there is now no red led light and no blue led light.

I don't think it is the power supply. I think it *might* be the USB-C connector, but I am not sure.

Technical support team, what should I do? Do I return this to you to check? Please advise. Order ID: #151249

Thank you!
#29977
Hi, I ordered a brand new 45W PC and it has the same problems. The red light comes on, the blue light blinks, but no boot. Then a few minutes later, even the red light does not even turn on.

I believe this is a problem with the USB-C female port on the board.

I would like to RMA this latte panda. Can somebody from dfrobot tell me the process for this?

Thank you