Romeo BLE rebooting with Devastator Mobility Platform

userHead dsuch 2018-09-01 16:10:28 4022 Views4 Replies
I have the same problem as another poster.

The Romeo BLE is mounted in your Devastator tank mobility platform. It is being remotely controlled via BLE using a mobile. Everything works as expected as long as you don't drive the motors over about 50% (i.e. motor duty cycle > 50%).

I'm monitoring the current to one of the motors using a INA219 and it isn't showing anything dramatic.

25% Duty Cycle: 287 mA
50% Duty Cycle: 414 mA

I'm also monitoring the battery voltage (9V) using a voltage divider (2 x 10k resistors). I think this is where the issue may be.

25% Duty Cycle: 8.75 V
50% Duty Cycle: 7.77 V

I suspect that when the motors are driven greater than 50% duty cycle the voltage is going low enough to trip the Romeo brown out protection.

Is there anyway to power the microprocessor separately from the motors? I had a look at the schematic for the Romeo BLE and there doesn't seem to be any way.
2018-09-12 15:40:00 I can still enter AT mode via the BLE link - but that seems to be it. I reset the settings to default via this but still no joy trying to upload a sketch or view a response in the serial monitor. I checked the UART settings and they are correct. Any ideas gratefully accepted. userHeadPic dsuch
2018-09-12 15:06:43 I read that updating the boot loader to v2 can help, so I tried that. Now I can't connect via serial at all. sigh... userHeadPic dsuch
2018-09-12 14:21:26 It appears that this is not a new issue - ROMEO BLE V1.0 NONE RESPONSIVE (viewtopic.php?f=12&t=2007&p=9117&hilit= ... ware#p9117).

There could be more than one problem. To test my theory regarding the power supply causing the reboot, I added a separate DFRobot motor driver ( This allowed me to power the Romeo separate to the motors. I'm using the Romeo to control the L298N (which of course is ridiculous since that is the point of getting the Romeo. Nevertheless, i'm still getting reboot issues.

I checked out the firmware on my Romeo and it was v1.93. So I updated to v1.97 but the same issue still occurred.

My next theory was that I was losing the BLE serial connection due to noise and the Romeo was rebooting when it auto reconnected. So I used a wired connection instead of the BLE link but still the same problem.

I'm afraid I am out of ideas - it would be nice if DFRobot made some sort of response.
userHeadPic dsuch
2018-09-04 15:58:18 No ideas? userHeadPic dsuch