Analog pH sensor v2 giving strange readings

userHead Craig.Jariz 2019-06-17 23:01:09 5912 Views5 Replies

I purchased the Analog pH sensor v2 back in early March, and for various reasons didn't get around to installing it this weekend. I know, I know, 30-day refunds or 90-day support, I've been busy so please just bear with me.

The meter readings around 4.5 both in the storage solution and in the provided ph 7.0 reference solution. Obviously, that's EXTREMELY off. What's even weirder is that when I put it into the provided pH 4.0 reference solution, the pH INCREASES to around 6.5.

So not only does the meter seem to read extremely incorrectly, it actually moves in the opposite direction.

Any thoughts from DFRobot or others? I'd really hate to be out $40 on this thing, I've had good lucky with everything else I've ordered and used before this...
2019-07-10 09:52:16 The main control board is a DFRobot Arduino Expansion Shield for Raspberry Pi:

It is hooked up to a Pi 3B. It is hooked up correctly, I have multiple other sensors that work fine.

The board is not wet. It has never been wet. It has only ever been used indoors.

Attached is a photo of how it is connected, straight to port A1 as specified in DFRobot's instructions and sample Arduino code found here: ... KR2_Wn6CiP

When hooked up in this way, sending the "enter" command to enter calibration does nothing, as the below video shows: ... zzmvLPyyEB

The probe also shows very little difference in being immersed in pH 7.0 versus pH 4.0 reference solution.

HOWEVER, if I used the code for the v1 meter ( (which is not correct, but I tried it anyways just to see if it would work), I DO see change between 7.0 and 4.0 reference solution. They're just both incredibly off with no ability to calibrate.

Please refund me the price of this product, I would prefer to purchase a replacement from a different company. If that is not something you will do after these several posts, I will no longer use DFRobot at all.
userHeadPic Craig.Jariz
2019-07-04 01:56:39 Sorry for the slow response, I've been out of the US.

Yes, I've tried to calibrate it. Multiple times. Which isn't really possible seeing as it starts 3 away from where it's supposed to and moves in the wrong direction, but I tried it anyway and of course I get results that make no sense.

Today's the 1-month mark on my order. This thing is clearly not working properly.
userHeadPic Craig.Jariz
2019-06-18 03:34:37 Whoops, let me clarify: I just purchased this at the beginning of the month. I made a different order a while back that I got confused with this one. So I'm well within the 30-day window for returns. userHeadPic Craig.Jariz