Can't receive data from Putty with DFROBOT WIFI shield V3

userHead copy-left 2016-04-20 23:21:26 12370 Views9 Replies

I have an issue with my WIFI shield, I can send data from my Arduino to Putty with the command Serial.write without any problem, but it doesn't receive data from Putty with this code :
void loop()
if(Serial.available()>0) //Print what serial received.
Can someone tell me if I did something wrong?
2018-12-10 11:18:57 I have the same problem. Transmits, but does not receive through serial. I've tried Putty, USR-TCP232-Test and my own iPhone software that works on many other devices. Has anyone managed to resolve this problem? userHeadPic craigt543
2018-01-06 16:49:31 Il got same problem I Can send data with Serial.print but Can t read with

Any solution ?

I mount Rx to Rx and Tx to Tx
Check the baudrate to 115200 (Serial.begin)
//Any code like blink... Will Never be executed
userHeadPic contact
2016-04-28 17:39:08 Sure it can do that, I thought you were using Putty or someting to test the wiki on your computer... anyway, may I have a look at your code? userHeadPic Leff
2016-04-26 17:51:16 My goal is to use the wifi shied with the Arduino in standalone for one of my projects, so I’ll not use it with a PC connected to it.
Is here no way of using it like that?
userHeadPic copy-left
2016-04-26 15:50:31 Hi,

How about using the software given on the wiki " USR-TCP232"?
userHeadPic Leff
2016-04-25 21:52:13 No, it's on the Arduino side to receive data on my Arduino. I tried the 2 other positions too, but it doesn't work either. userHeadPic copy-left
2016-04-22 12:29:02 Is the switch was on USB side?

(56.72 KiB) Downloaded 5724 times
userHeadPic Leff
2016-04-21 15:48:36 Hi,
I use this one : ... xiFcrD43cw
userHeadPic copy-left
2016-04-21 09:54:32 Hi copy-left,

May I know which WIFI shield you are using? Can I have a link? thx
userHeadPic Leff