GPS-GPRS-GSM-Shield-V3.0 auto shut off w/ serial connection

userHead yuesu87 2016-05-07 12:07:52 10271 Views4 Replies

I had been trying to get a GPS-GPRS-GSM-Shield-V3.0 to send GPS data over either HTTP or FTP via AT command.
While trying to setup the GPRS network, a bug occurred midway (it started transmitting random char.) and right after, I can't get the shield to receive AT commands.
I have tried restarting the shield multiple times, each time the shield initiate normally with Stat and Net LED turned on. The moment I connect to the shield via serial, both green light would turn off. I had tried diagnosing the problem with Module Tester. On the rare occasion a connection was establish, it would display a response like "normal power off".
The arduino has been setup with the 1.5 sec gsm timing and digital high on pin 3&4. I have a fully charged 7.4V 1c lipo connected to the arduino power socket. S1 pin is set on Comm, S2, on USB, and UART pin on GSM.
Can someone help me solve with this issue?
Thank you!
2016-05-17 12:15:23 Hi Leff,

The issue has been solved! Thank you very much!
userHeadPic yuesu87
2016-05-11 16:21:35 Oh, sorry for belated.

That post is meant to receive GPS location on a phone, so the code (you could download in that post or on TEL0051'S wiki) will check the GPS data format, if no GPS data was received, no message will be sent out to your phone.

Tel0051's wiki is poor, hard to read. But I revised part of it to make it more readable, you can follow this section How to drive the GPS Mode via USB port to used it in AT command, to understand how it works.

And to your problem, it should be the AT command data format wrong, the serial monitor should be set as 9600 and carriage return

(2.7 KiB) Downloaded 5468 times
userHeadPic Leff
2016-05-07 13:38:15 Hi Leff,

Thank you for your swift response.
I have followed your instructions, by pressing on the Reset button, the Sat LED is on and Net LED is blinking.
On all the coolterm, a '.' was sent from shield. However, it doesn't respond to any serial command.
The shield is placed right next to window and I have waited a little while. Nothing changed.
Can you clarify the reason for which the shield need to be placed outside when I am only using GPRS?
Is initiating GPS part of the startup procedure of the shield?
userHeadPic yuesu87
2016-05-07 12:22:54 Hi Yuesu87,

Just by pressing Reset button again will work, and in this post, these is a NOTE in step5. Place the GPS... module outside about the "normal power off" explaination.
userHeadPic Leff