Bluno General Arduino

Bluno Beetle, Can't upload sketch after updating firmware

userHead Account cancelled 2016-10-17 04:04:43 5914 Views7 Replies
I recently started the beetle tutorial ('', ('') ? '' : 'https://www.dfrobot.com/index.php?route=DFblog/blog&id=283') and uploaded the basic sketch just fine, but I ran into some trouble updating the firmware.

I used the blunoFWDownloader to load the firmware found here ('', ('') ? '' : 'https://www.dfrobot.com/forum/viewtopic.php?f=18&t=1733'), and it loaded successfully. After uploading, my computer no longer recognizes the beetle as a usb device. The beetle wiki page directed me to try the 1.8 firmware here ('', ('') ? '' : 'https://www.dfrobot.com/wiki/index.php/Bluno_SKU:DFR0267#Bluno_Basic_Demo'), and I tried the 1.97 beetle firmware from the github page, but the beetle is still not recognized.

The beetle appears in my device manager as an unknown usb device, and currently the power led is a solid red, and the link led is flashing green.

Am I using the correct firmware and uploading it incorrectly, or is there a different firmware file that I should be using? Thanks for the help

Device: SKU:DFR0339
IDE: Arduino 1.6.12
OS: El Capitan 10.11.3
2016-10-31 17:32:45 Great! :) userHeadPic Wendy.Hu
2016-10-29 11:54:32 I used the blunoFWDownloader to install version 1.8e from the link you sent, and now everything is working perfectly. Thanks for the help! userHeadPic theokanning
2016-10-28 18:56:11 Maybe you can try to update the other version firmware, since I dont know which version the beetle used before. Here are some firmware link, you can try again:make_clickable_callback(MAGIC_URL_FULL, ' ', 'https://www.dfrobot.com/wiki/index.php/Bluno_SKU:DFR0267#More', '', ' class="postlink"')

Its a little strange for your problem.
userHeadPic Wendy.Hu
2016-10-27 23:30:14 I was just following along with the beginner tutorialmake_clickable_callback(MAGIC_URL_FULL, ' ', 'https://www.dfrobot.com/index.php?route=DFblog/blog&id=283.', '', ' class="postlink"')

I'll be happy with any working version of the firmware.
userHeadPic theokanning
2016-10-27 16:51:00 May I know why do you want to update the firmware? userHeadPic Wendy.Hu
2016-10-26 12:00:08 Thanks for the response! I tried updating the drivers as you said, but it didn't fix the problem. Is there a way to flash the original firmware that came with the board? userHeadPic theokanning
2016-10-19 17:42:55 Maybe you need to update the driver. Open the files of the Arduino, if your computer is 32- bit system, run dpinst-x86.exe ; if your computer is 64-bit, run dpinst-amd64.exe.
('0', 'QQ图片20161019173834.png')
userHeadPic Wendy.Hu