ArduinoGeneral

Issue with ESP8266 Wifi Bee

userHead helicampro 2016-12-01 02:25:30 2103 Views5 Replies
Hi everyone! I'm looking for someone able to help me. I have a problem with a Wifi Bee: sending some official ESP8266 AT commands (among which AT+PING, AT+RESTORE, AT+CWJAP_CUR...) I get an ERROR as the only reply. I have been suggested (here:make_clickable_callback(MAGIC_URL_FULL, ' ', 'http://bbs.espressif.com/viewtopic.php?f=16&t=3123', '', ' class="postlink"') ) a tutorial to flash the command set, but I still don't have all the AT commands working (some more, some less than before). I've tried with another brand new WiFi Bee to make sure I did not screw something during my first attempts, but the issue is confirmed. What can I do? Thank you!!

P.S. I cannot upload a picture, you can see it attached to my very same question posted in the product page, here:make_clickable_callback(MAGIC_URL_FULL, ' ', 'https://www.dfrobot.com/index.php?route=product/product&search=wifi+bee&description=true&product_id=1279', '', ' class="postlink"')

P.P.S. the preview shows a weird formatting of the URLs, I hope they are clear in the final post
2016-12-30 11:55:05 Hi

What problems encountered? :)
userHeadPic Wendy.Hu
2016-12-29 22:22:37 Has anyone ever managed to interact with this shield on the leonardo & xbee socket R3 controller? userHeadPic oscarrafaelcampos
2016-12-21 15:58:27 Hi helicampro,

Sorry for the delay.
I made a confirmation with my colleagues, then the reply is that the module will work well in the STA mode, but cant support all AT commands in the AP+STA mode. So far, probably its the bug of the official and seems to be no better way to solve the bug. I dont know if the STA mode can meet your needs? Sorry for your troubles. :(
userHeadPic Wendy.Hu
2016-12-20 23:21:40 Hi! Thank you for confirming the issue. Are there any news about the fix? As I wrote, I had already tried to upgrade to the latest firmware, but I still had not all the AT commands working (some more, some less than before). I'd like to understand whether the solution is about to arrive, or it has a long way to go. userHeadPic helicampro
2016-12-01 13:24:05 Hi helicampro,
Confirmed. Thank you for your feed back.
I've noticed our R&D team and they will provide a new firmware to deal with this problem.
Before we fix our package, you can try here to upgrade your firmware:make_clickable_callback(MAGIC_URL_FULL, '
', 'http://bbs.espressif.com/viewtopic.php?t=1613', '', ' class="postlink"')

PS: there are some problem on our forum, our software team is trying to deal with it. Sorry for the inconvenience.
userHeadPic Angelo.Qiao