Bluno General Arduino

BLUNO MEGA 2560 Firmware Update problem

userHead ahmed.sweleh 2017-06-27 13:17:20 6408 Views4 Replies
I tried to updated my BLUNO MEGA 2560 firmware to the latest one from DFrobot but now it wont let me upload any sketch to it using arduino IDE through USB cable. I tried to flash it with other firmware but no luck. What is the problem? is the board briked? please help
2019-01-06 07:01:10 I am experiencing the exact same issue... ive tried every version in the 1.9 FW zip from github using the Bluno FW downloader... i have had minor success uploading code using the icsp and an Uno as ISP

But the USB upload does not work at all...

The USB communicates with the BLE chip and enters AT mode just fine..

But there seems to be no communication between the BLE/USB and the MEGA2560
userHeadPic Fortin Beau
2017-08-25 14:47:26 Have you tried to use the BlunoFWDownloader to upload the firmware?
https://www.dfrobot.com/wiki/index.php/ ... 8_or_later
userHeadPic robert.chen
2017-07-03 03:38:11 I have went through all the updates available on github from DFrobot none of them work. Right now I have firmware 1.94 uploaded and this is the message I get when trying to upload from Arduino IDE
Arduino: 1.8.1 (Mac OS X), Board: "Arduino/Genuino Mega or Mega 2560, ATmega2560 (Mega 2560)"

Sketch uses 1462 bytes (0%) of program storage space. Maximum is 253952 bytes.
Global variables use 9 bytes (0%) of dynamic memory, leaving 8183 bytes for local variables. Maximum is 8192 bytes.
avrdude: stk500v2_ReceiveMessage(): timeout
avrdude: verification error, first mismatch at byte 0x006b
0x01 != 0x00
avrdude: verification error; content mismatch
avrdude: verification error; content mismatch

This report would have more information with
"Show verbose output during compilation"
option enabled in File -> Preferences.
userHeadPic ahmed.sweleh
2017-06-27 17:01:55 What's the version of your firmware? What if you use an earlier firmware and test the code again userHeadPic robert.chen