Cannot program miniQ 2WD?

userHead Account cancelled 2017-07-25 07:25:03 1839 Views1 Replies
We bought several ROB0081 miniQ 2WD v2.1 kits for an educational program next week. We thought we'd test them out before-hand, of course.

These are Arduino Leonardo based systems. We find we cannot program them, and wondering what is missing?
We have tried both using Matlab with the Arduino add-on installed as well as the Arduino IDE, using Mac OSX 10.12.5
Matlab requires installing a server on the Arduino. It recognizes the board and begins installation, then drops out saying it cannot program the board, and to check the port and board settings (which are correct). I notice the port disappears and cannot be reselected unless I power the miniQ off and back on.
Arduino IDE starts programming (using blink example sketch), and then drops out saying it couldn't find a board on the port selected (the same port it just gave a board info report on.
I have tried removing batteries and using only USB, I have tried with fresh batteries, I have tried with freshly booting/resetting the miniQ right before upload.
Ideas? We've got to get these working asap!
2017-08-01 15:34:45 Have you install the driver of the board? Normally, when you plug the board to PC, the device manager will show the port, and you can install the driver by right click the port. Then if you press the reset button, the device manger will refresh to show the board is connected userHeadPic robert.chen