Easy IoT General

FireBeetle ESP32 IOT UART issue

userHead Horan Brendan 2017-08-02 17:16:09 5042 Views4 Replies
Hi,

I have a FireBeetle ESP32 IOT. (DFR0478 )
I am trying to connect the Gravity: Laser PM2.5 Air Quality Sensor For Arduino(SEN0177)
I have the sensor powered from a separate 5v power source.

I am running MicroPython on the FireBeetle.
As soon as I connect the RX and TX pins of the sensor the FireBeetle freeze/hangs.
It responds again if I remove the RX and TX pins.

I have tested the sensor on my Arduino and it works fine.
TX and RX voltage levels are 3.3v, thus will work with FireBeetle.

Please help understand why the FireBeetle hangs when I try use the UART.
2017-09-03 14:49:34 Doing something like :
Code: Select all
from machine import UART
uart = UART(1, 9600)
uart.init(9600, bits=8, parity=None, stop=1, rx=25, tx=26)
Seems like I can read the device (pm2.5 sensor), unsure if the data it is reading is correct yet :D

However using the UART pins as listed on the board or on the Gravity shield will still cause the ESP32 to freeze.
So there still is some issue with the listed UART.
userHeadPic Horan Brendan
2017-08-25 08:01:23 I have not tried mapping the RX/TX pins to another mapping.
I was using D0/D1 as the wiki lists :
https://www.dfrobot.com/wiki/index.php/ ... U:_DFR0478

let me give a go at mapping it to IO25/26 and see.
thanks
userHeadPic Horan Brendan
2017-08-24 14:52:15 As far as I know UART of ESP32 could be mapped to any pins, have you tried D3,D2, which are IO26,25 as RX/TX userHeadPic robert.chen
2017-08-17 15:45:05 I have sent an email to tech support.
l hope they can sort it out.
Will post details here when I get them
userHeadPic Horan Brendan