Maqueen plus with microbit V2 has non functioning IR sensor

userHead Robvan der Ouderaa 2022-10-09 01:08:00 1802 Views4 Replies

Hi,

 

I would like to report that the Maqueen plus with a microbit V2 can not read the value of the IR sensor that should be on pin16 (GPIO3). I measured its output value as 0.9v and this is too low for the Maqueen plus to see this as a HIGH level. After soldering a resistor of 820 ohm to 3.3v this was resolved and the microbit could read the IR value. I asked a college to test the same issue on another Maqueen plus with microbit V2 and he got the same result.
So you may want to take this up with your production department for a later version of the Maqueen plus to fix this hardware issue.
It would also be nice if there was some code for reading a IR remote control for the Maqueen plus.

 

Kind regards,
  Rob

2023-07-04 02:36:44

HiI've just boght MaQueen Plus V2 but cannot get any reading from → the light sensor (LEDs on the micro:bit?), the reading is 0→ the ultrasound sensorHow can I find out if this is a hardware issue?Thx, Eva

userHeadPic Eva.Ravnikar
Yeez_B wrote:

Sorry I didnot understanding your question clearly.

Do you mean you could not get right value from the ultrasonic sensor? And also could not get the LED of the MicroBit on?(I think the Maqueen donot have the Light sensor)

Please try these code to see if the Maqueen gives you the corresponding return.

 

LED/UltraSonic sensor test:

https://makecode.microbit.org/_VFEdmdXLuejA

 

You need to connect the ultrasonic sensor to TRIG(P13) and ECHO(p14)

 

2023-07-04 14:23:27
1 Replies
2023-02-24 11:31:43

Hi

Thank you very much for your advice.

We have updated the Maqueen plus series to micro:Maqueen Plus V2 (Ni MH Rechargeable Battery)(SKU:SKU:MBT0021-EN), the problem you mentioned has been solved, you can check in the following link.

https://www.dfrobot.com/product-2026.html

Hope it can help.

userHeadPic NeloKin
Rkss wrote:

May I ask, Any IR remote 1838 would do or you should something else?

 

2023-10-24 02:20:42
1 Replies