Maqueen Plus V2 + Mechanic Beetle not usable

userHead mirw 2022-11-06 06:36:31 1748 Views5 Replies

Hi

I've bought Maqueen Plus V2 and Mechanic Beetle but unfortunately it seems they are not working correctly. The first thing is that https://github.com/DFRobot/pxt-DFRobot_MaqueenPlus_v20/ library which I'm using doesn't have Servo Control block at all. I tried writing directly to I2C 0x10 register values 0x14, 0x15 and 0x16 (which I found in older versions library) but also without a success.

Is there a way o control servo on Maqueen Plus V2? If not, I am really dissapointed as it is stated that both products are compatible. 

2023-10-28 20:39:38

My maqueen plus V2 only has ports P0, P1 and P2 on the board and no servo ports. Can you connect servo motors to ports P1 or P2? With which I2C address?

userHeadPic JarkaArnold
2023-10-08 23:37:49

Hi, I'm having the same problem. My Maqueen plus V2 does not have servo ports S1 and S2. Is it possible to connect Maqueen Mechanics to the port Po, P1, P2. With which address?

userHeadPic JarkaArnold
2023-04-13 02:23:53

userHeadPic Jessica.Law
2022-11-07 15:41:32

OK, found it. In the older Maqueen versions there is a special servo control block from the provided library but for V2 to work I just used generic servo block. 

userHeadPic mirw
Mik.Lorimer wrote:

Hi, I'm having the same issue could you tell me how you fixed it, I'm guessing you have maqueen plus v2.1 which does not have servo S1, S2 etc ports but P1, P2 on the board?

2023-05-10 04:51:54
1 Replies