Troubleshooting

FireBeetle ESP32-E Boot Mode

userHead MonkerZ 2023-03-15 08:54:27 2494 Views6 Replies

I feel as if I am pretty tech-savvy, but after days and days of learning about this device, I have rethought it. I think I spent 12 full hours trying to get this device into boot mode. I am trying to flash my device. I can never activate download mode. So how does one get into boot mode with this device?

 

Is Button 27 the boot mode?

 

Here is the error I get:

 

"C:\Program Files (x86)\Thonny\python.exe" -u -m esptool --port COM3 erase_flash
esptool.py v4.4
Serial port COM3
Connecting......................................

A fatal error occurred: Failed to connect to Espressif device: Wrong boot mode detected (0x13)! The chip needs to be in download mode.
For troubleshooting steps visit: https://docs.espressif.com/projects/esptool/en/latest/troubleshooting.html

Erase command returned with error code 2

 

If I hold the button, it will flash red, green, and then blue. I have tried hundreds of methods on how long to hold, press the reset button, and I have tried everything.

 

Any help would really put my brain to rest.

2023-04-02 01:16:14

IT WORKS. I did it correct i think it just wasnt connected. 

userHeadPic juli.iiian
2023-04-02 01:12:09

I am sitting here since 2.5 hours and its still not working. I tried everything you did, but it does not work. So you just connected GPIO 0 with GND (https://dfimg.dfrobot.com/nobody/wiki/d030e91463063484c89ad0dae50ed276.png Pin 0 colored orange in the image) it does not work. Do I need to press anything with that?

userHeadPic juli.iiian
2023-03-15 14:16:31

To enter the downloading mode of FireBeetle 2 ESP32-E IoT Microcontroller(SKU:DFR0654), GPIO 0 and 12 should be low with GPIO 15 equal to high.

userHeadPic NeloKin
MonkerZ wrote:

So I need to ground out GPIO 0 or 12, or do they both need to be grounded at the same time? 

2023-03-15 18:22:12
NeloKin wrote:

Both of them, according to the datasheet.

2023-03-16 14:22:19
2 Replies
2023-03-15 09:38:29

So I post this and 5 minutes later finally found a post saying to link GPIO 0 to Ground and it will enter boot mode. It seemed to work. Is this really the way to do this?

userHeadPic MonkerZ