A01NYUB Ultrasonic Sensor no data, SEN0313

userHead Katrin.Kat 2023-06-28 17:49:30 244 Views7 Replies


I bought A01NYUB Ultrasonic Sensor with the Raspberry Pi IO Expansion Board and I use a Raspberry Pi 4B. I have followed the instructions accordingly https://wiki.dfrobot.com/A01NYUB%20Waterproof%20Ultrasonic%20Sensor%20SKU:%20SEN0313 and https://www.dfrobot.com/forum/topic/317449. But unfortunately I still get “No data!”. Why do I not get any distance data?

Thanks for the support in advance!

2023-07-06 21:45:04

It works fine without epansion board, see also https://www.dfrobot.com/forum/topic/312660

userHeadPic Katrin.Kat
2023-07-04 23:21:50

Are you using jumper wires? If yes, test them too.

userHeadPic bidrohini.bidrohini
Katrin.Kat wrote:

Do you mean between RasPi and Expansion Board?In this case, no.

2023-07-05 21:46:51
1 Replies
2023-07-03 17:21:00

No difference, still no data. I don't see any difference in the code either.

userHeadPic Katrin.Kat
Katrin.Kat wrote:


We have made some progress and have found that it is because the io extension hat huts off after a while. When the board is working we get distance readings. After a while the extension shuts off. Is this a defect or a setting issue? 

Thanks for the support in advance!

2023-07-04 18:51:59
jenna wrote:

It seems like the expansion board has some errors. You can consider changing the expansion board if it works well between RasPi‘s GPIO and SEN0313. 

2023-07-06 11:39:11
2 Replies
2023-06-29 10:09:35

Please try the latest sample code. We will update the wiki.


userHeadPic jenna