DFrobot DHT11-Module not working

userHead arduinofish 2012-04-19 01:16:46 6852 Views4 Replies

i just got a Mega Sensor Shield V2.1 and a DHT11-Module. I plugged the modul o Analog-Pin 15. Copied the code of the wikipage, just altered the pin to 15 as it should be............ and got:

"dht11 start condition 1 not met"

What happen? i have just no clue. The cables are connected right.

2012-04-20 09:47:04 Hey,

Glad it worked!

Next time I recommend you have a look through our wiki's. We provide Arduino sample codes, and connection diagrams for most of our sensors, modules, and shields. Its a good starting point. Plus, it will be easier for us to trouble shoot any problems you might be having, since we are more familiar with our sample codes.

userHeadPic Hector
2012-04-19 20:13:25 lol.... just copied camels' code... changed the port to 55 (for Analog 1) and it works.

i tried to get it work for 5h yesterday evening.........

Thanks a lot
userHeadPic arduinofish
2012-04-19 20:07:58 actually i changed to that DHT11Lib (DHTLib) from There i get an time out error. I'll give the Camel-Code a try :) userHeadPic arduinofish
2012-04-19 10:29:30 Hi Peter,

Which code are you using? The first sample code on the wiki or the second one contributed by Camel? I think it would be easier to modify the code contributed by Camel since it is more Arduino friendly. The first sample code also relies on Port C, which you would need to look at the datasheet for the MCU to be able to change the port to the appropriate port for the MEGA.

userHeadPic Hector