ArduinoGeneral

Arduino Mega + DfRobot USB SHield + Android 2.2

userHead robb83 2012-07-01 23:43:57 4145 Views2 Replies

Hi!

I would like a bit of help, please. 
I'd like to connect my android 2.2 phone with arduino, via ADB.

The items: 
- arduino mega 2560R3( not ADK)
- DFRobot usb shield
- android 2.2
- MicroBridge library http://labs.arduino.cc/uploads/ADK/GettingStarted/arduino_bundle_ADB.zip]http://labs.arduino.cc/uploads/ADK/GettingStarted/arduino_bundle_ADB.zip

I tried SS = 10 and SS = 53, but neither worked, i also tried switching the jumpers and also tried the commented out part of the source code. 
I could use my telephone program on pc with ADB. 
The serial monitor writes this: "Error: OSCOKIRQ failed to assert". 

And i think it stops at this line (waiting forever): 
 while (!(max3421e_read(MAX_REG_HCTL) & bmSAMPLEBUS));

And finally i connected keyboard to arduino, with USB Library 2.0, by leaving all on default (ss jumper = 10, int = 9) and work. 

What else could i try, what are the good settings? 


Thanks!

2012-07-02 12:27:25 glad to see you figured it out and share the result with us. Really appreciate. Every little help will make the community better.

Cheers Robb83
userHeadPic R2D2C3PO
2012-07-02 02:16:11 I looked over the code of USB Host Library 2.0 and MicroBridge, and when i saw that MicroBridge uses GPX, i took it out, and now it works. Now i'd just have to know what GPX does...

Attached diff files (based on [url=http://microbridge.googlecode.com/issues/attachment?aid=90004000&name=MicroBridge-Arduino-Patched-IDE-1.x.zip&token=2PqxZpvPsTd08KDntjCOXuWvuQg%3A1341091146361]http://microbridge.googlecode.com/issues/attachment?aid=90004000&name=MicroBridge-Arduino-Patched-IDE-1.x.zip&token=2PqxZpvPsTd08KDntjCOXuWvuQg%3A1341091146361[/url]).
userHeadPic robb83