TELEMATICS 3.5" TFT Touch LCD Shield SKU: DFR0387

userHead Account cancelled 2017-04-03 23:55:22 2718 Views4 Replies
recently i order a touch lcd from dfrobot and while im trying to print a sentence using dfrobot code example

its show me only the first letter from the sentence

this the code im using to print

#include <Arduino.h>
25 #include <SPI.h>
26 #include <MultiLCD.h>
28 LCD_R61581 lcd;
30 void setup(){
31 lcd.begin();
32 lcd.setFontSize(FONT_SIZE_MEDIUM); //set font size
33 lcd.setColor(RGB16_RED); //set strings color
34 lcd.println();
35 lcd.println();
36 lcd.println("DFRobot!!!");
37 lcd.println("TELEMATICS LCD SHIELD V1.0");
38 lcd.println();
39 lcd.setColor(RGB16_WHITE);
40 }
42 void loop(){
43 }

even i try too much in others codes the functions println (""), print("");only print one character from the sentence

i had open lcd libraries also and check it and i didn't found any print function that i can use

any suggestions ?
2019-01-12 09:06:31 THANKS IT WORKS userHeadPic dallasmcneil
2018-01-02 13:26:42 Hi
I used a mega 2560 to test the code with DFR0387 and it works well, I don't think it is three exclamation cause the error message, since the error message means unable to contact with bootloader, how about burn the bootloader of your mega and try again to see if the problem happened again
userHeadPic robert.chen
2017-12-31 14:28:38 I was having the same problem using the IDE version 1.8.6.
When I tried v1.6.2, the problem appears to be fixed. Thanks!

HOWEVER, note that this example has a line of code in which there are three exclamation points in a row (DFRobot!!!) on line 36. This caused me lots of problems when trying to upload it to a MEGA 2560 R3 (several different MEGA boards were tried). But it kept giving me errors like: "avrdude: stk500v2_ReceiveMessage(): timeout"

After some searching, I discovered that "!!!" (three exclamation points in a row) causes the Mega 2560 bootloader to go into Monitor mode from which it can not finish programming. See ... ge-timeout for more discussion.

The fix is obviously to edit the line to not use "!!!".
It would probably be a good idea to not provide sample code that has a problem like this!
userHeadPic lacomj
2017-04-05 11:44:01 Hi

I am guessing its possible to be a compatibility issue, please use 1.0.5 IDE to complie, try again.
userHeadPic Wendy.Hu