Delta 3, Unable to update BIOS or boot from USB

userHead Jbkelley 2023-05-11 06:57:03 563 Views3 Replies

Unable to boot for USB 3 or update BIOS.  Current version of BIOS is not the production launch version.  It is dated 03/24/2022 11:114:10

 

I've tried following the instructions for formatting 32bit fat.  copying 2 directories and single file on to the a USB flash and a USB SSD drive.  I've also tried installing the same files onto the UEFI SSD installed via M2 that shows up in the BIOS.  Non of the USB devices show up in the BIOS.  None of the 3 tried methods are useable for updating the BIOS.  Also uSD card doesn't work either.

 

 

2023-05-11 09:29:42

Hi, I have met the similar problem either. When I tried to re-install the Windows 10, the USB drive just didn't show up in the BIOS.

But I tried the following steps to let the USB drive appear again.

 

1)In the BOOT page of the BIOS, I set all four BOOT OPTION as Disabled

 

2)Then in the SAVE&EXIT page, I Save Changes and Exit for a serval times.

The BIOS page will refresh everytime you Save Changes and Exit.

And because you didnot choose and Boot Device, so it won't get boot.

 

And you will see the USB DISK in the Boot Override.

Just choose it, and you will boot from the USB Driver.

 

Hope it could help you!

userHeadPic Yeez_B
2023-05-11 09:19:29

Hello,

 

I think I have seen a similar post on Lattepanda's official website: https://www.lattepanda.com/forum/.

please check it out, I forget the exact solution to this problem.

 

Regards,

userHeadPic xingzhao.zhu
2023-05-11 07:08:37

userHeadPic Jbkelley