TroubleshootingGravity

BLE sensor beacon with SEN0114 - failed to connect to device

userHead [email protected] 2024-02-19 02:18:06 179 Views5 Replies

Hello all,

I have a TEL0168 BLE sensor beacon connected to a SEN0114 soil moisture sensor. I'm using a DTECH USB to TTL serial converter cable. I've followed the steps in the TEL0168 wiki to configure the device. 

https://wiki.dfrobot.com/_SKU_TEL0168_Fermion_BLE_Sensor_Beacon

 

I'm able to probe and connect to the device the first time. I have tried this with 2 of the same BLE sensor beacons. When I get to the test device part, I select run in ram. I then see this message in the attached file: 20240218_120812.jpg

 

These are the current XO settings. I have no idea what to set them to: 20240218_115835.jpg

 

After I close the first error dialog the run in ram process completes. When I try to run it again, I get the error IN100 Connect can't connect to device. I try to probe and connect and it finds my device on COM4. I get the same error - cannot connect to device. I exit the NanoBeaconConfigTool.exe. I unplug the USB cable and restart my windows 11 PC. At this point I can no longer connect to the BLE sensor using NanoBeaconConfigTool.exe. It looks like I have bricked 2 BLE sensors, but I have no idea why. Any help would be greatly appreciated.

 

Thanks

 

icon BLE sensor Beacon Error.zip 2.48MB Download(0)
2024-03-01 01:06:29

Hello,

I'm using the updated wiki configuration. I removed the coin battery and USB cable and then inserted both back into the device. I was able to connect to the device on COM4. I went through the wiki configuration including the section 10 update. When I click run in ram, I see this message. 

 

Run in ram will work one time. When I try it again I get the cannot connect to device message. I have a second BLE sensor that I will try this configuration on. 

userHeadPic [email protected]
Yeez_B wrote:

Hello,

I have tested the Beacon with the .cfg file provided by you.

After I click Run in RAM, the Beacon cannot be connected.
But after I power off and on Beacon is reconnected.
I have emailed you the test video for your reference.

2024-03-06 15:29:30
1 Replies
2024-02-29 16:47:13

This parameter is supposed to keep the BLE signal optimal. Even with 8 nothing happens, except that the BLE signal gets worse.

 

And in general, "RUN in RAM" does not bricked the beacon, because the configuration in RAM will be erased after completely cut off the power to the beacon.
Only "BURN/Program" will brick it.


Would you be able to share your configuration in the NanoBeaconConfigTool so that I can make test.

 

You could “SAVE” the certain configuration by click the “SAVE” in the right, and a .cfg file would be generate.

userHeadPic Yeez_B
2024-02-29 13:58:07

Updated the content "10. Crystal Capacitance Matching" in WIKI.

Please make sure you choose "run in ram" instead of "Burn/Program". Please try again after powering off the BLE sensor beacon completely without connecting any power source including button cell battery.

userHeadPic Xiao
2024-02-29 03:52:01

Its been over 2 weeks since I posted this question with no replies. I don't mind being a beta tester, but I really need some direction if I'm going to use the BLE sensors. The ESP32 LoRaWan boards work very well. I was interested in the simplicity of the BLE sensors, but a LoRaWan solution might be better.

userHeadPic [email protected]