ArduinoGeneral

[SOLVED] Bluetooth Bee V2 + Arduino Uno R3 + Xbee Shield: AT mode?

userHead luke_bonham 2013-06-16 19:28:24 5336 Views3 Replies
Hi, I'm struggling to enter AT mode, without success.

I have an [url=http://arduino.cc/en/Main/arduinoBoardUno]Arduino Uno R3[/url] equipped with an [url=http://store.arduino.cc/it/index.php?main_page=product_info&cPath=11_5&products_id=5]Xbee Shield[/url] which mounts a [url=http://www.dfrobot.com/wiki/index.php/BLUETOOH_BEE_(SKU:TEL0023)]Bluetooth Bee V2[/url].

As [url=http://www.dfrobot.com/wiki/index.php/BLUETOOH_BEE_(SKU:TEL0023)]wiki[/url] says, I placed the module in AT mode (I assumed turning from left to right the 'AT mode' switch on it) while off, then plugging the usb cable to the PC and opening Arduino IDE Serial Monitor.

Lastly, I set baud rate to 38400 and text to "both NL & CR".

But I still can't enter AT mode: if I send 'AT' or other commands, I don't receive answer.

What am I doing wrong?

I assume when the wiki says 'USB Xbee converter' it means the emulation via software provided by drivers for the usb cable, or... don't tell me I have to buy something like [url=http://www.dfrobot.com/index.php?route=product/product&product_id=72#.Ub2g9D7N-rs]this[/url]?

Thanks in advance for any reply, and sorry if I am too elementary.
2013-06-17 23:39:13 Ok, I solved removing the microcontroller [b]before[/b] following the wiki. userHeadPic luke_bonham
2013-06-17 16:12:52 Thanks for your time.

In his post, madfin said he did short cable jumper from Bluetooth Bee Dout pin directly to Arduino Rx pin to make it work.

I don't know a thing about electronics, could you please explain me how can I do that?

Moreover, a [url=http://www.cooking-hacks.com/index.php/documentation/tutorials/arduino-xbee-shield]tutorial[/url] on the Xbee shield I'm using says (Step 4) I should remove microcontroller from my Arduino board in order to enter AT mode.

Problem is: how can I remove it? It seems so strongly attached to the board and I'm afraid to break it.
userHeadPic luke_bonham
2013-06-17 11:15:44 Hi

Maybe you can refer to the related problem of using Bluetooth with Xbee shield like:
[url=http://www.dfrobot.com/forum/index.php?topic=757.msg3465#msg3465]http://www.dfrobot.com/forum/index.php?topic=757.msg3465#msg3465[/url]

Also you can research the related post in the forum. ;)  Hope it is useful for you.

Best
userHeadPic Phoebe