DFrobot DHT11-Module suddenly not working

userHead nosk8fx 2014-10-31 19:16:51 4796 Views7 Replies
Hello all,

first of all, I'm using MSP430 (with G2553) and DFrobot IO Expansion Shield, but the code and everything else can be the same from Arduino in Energia.

So, my problem is DHT11 from DFrobot ... whien I first got it, it worked great for a month or two. Sample code and library from DFrobot links ([url=][/url] and this is it.

But suddenly I got Checksum error (not Time out when disconnected), but nothing changed. I downloaded the example code and library again, deleted old ones, but still got the errors. As said, I get Checksum error and readings .0 and .4 for humidity and temperature, respectively.

I thought OK, the Module died, so I ordered 2 new ones. Now I'm testing with 3 same Modules, but the results are the same. The only difference is that I sometimes get .0 and .4, or .0 and .0, or .0 and .8.

I also tried with two MSP430 and two Shield, various cables, of course the MSP and Shield with just that sensor, and the code only for DHT ... no luck, still getting the Checksum error.

I also checked the Project code and the Library several times, but I can't find any weird things. And since this is original from DFrobot, there should not be any weird things. Please note that I don't consider myself as a beginner :).

The weird thing here that this Module worked great at the beginning, but suddenly it just stopped. If the problems occurred from the beginning, I would somehow understand, but now I'm out of ideas.

Does anybody has some other ideas what could be wrong?

I would be very thankful.

Best regards,
2014-11-10 14:59:51 this is true, but still why would that change with the newer version? userHeadPic nosk8fx
2014-11-10 10:54:37 Cheers,

I guess it requires a standard voltage.
userHeadPic Grey.CC
2014-11-10 04:47:51 well, the problem was in the Energia version ... with 12 it was working great, with the recent 13 it has problems.

i didn't thought about it earlier, but still the question remains why ... but that should probably Energia sort out :).

thanks for trying to help.

userHeadPic nosk8fx
2014-11-05 14:15:57 to go through the list of connected things:
- MSP430 ([url=][/url])
- IO Shield ([url=][/url])
- DHT11 ([url=][/url])

sometimes I had Xbee inesrted into the slot, sometimes not, but no external power source, except USB connector on MSP430. I also tried directly with 2 AA batteries (on Vcc and GND), but the results are the same.

I get the message from the code below, but of course this is from sample code:
Serial.print("Checksum error,\t");

I will post the photo of the equipment and some screenshots ...
userHeadPic nosk8fx
2014-11-05 10:20:54 Uhm~
Do you have other MCU board with 5V output? Like xbee adapter with 5V output?
I am not sure whether it caused by the voltage.
Could you attach an error information screenshot?
userHeadPic Grey.CC
2014-11-04 01:06:33 its directly to USB, so 5 V, but the board cares for 3.6 V.

otherwise, the Shield is directly for MSP430, so it is attached directly on the board, and the sensor with 3 pins to the Shield. nothing to dfrobot, so to say :) ... also I have other sensors from DFrobot, and they work fine, also DHT11 worked till ... I don't know what changed, but I don't get the right value, just Checksum error.

any ideas?
userHeadPic nosk8fx
2014-11-03 09:59:05 Welcome nosk8fx,

What is your power supply?
I remember MSP430 is low power consumption device. its working voltage is 1.8~3.6 V.
Could you attach your connection diagram?
userHeadPic Grey.CC