WaveShare screen compatibility

userHead alawrence 2017-03-11 07:20:22 6663 Views6 Replies
I bought this touchscreen: for use with a Raspberry Pi. I'm trying to replace the Raspberry Pi with the LattePanda.

When I plug the touchscreen into my Windows 10 Pro 64-bit laptop it comes up immediately with a resolution of 1024x600.

When I plug it into the LattePanda the touchscreen finds no signal. The LattePanda works fine with my standard desktop monitors. If I do a hard reboot of the LattePanda the touchscreen does display the LattePanda splash screen at what appears to be the native resolution of 1024x600.

Does the LattePanda need drivers for this touchscreen? It comes up as Generic PNP Monitor on my laptop without prompting me for driver installation.

What can I do to get this screen to work with my LattePanda?
2017-05-26 23:50:32 Alawrence,

I was able to get these two devices to work together. I installed a fresh copy of Windows 10 onto the LattePanda. After testing and playing around it seems as though the problem is the Intel graphics driver. For some reason once that is installed the screen will no longer work. I'm still looking for the correct driver to install, in the meantime this will work.
userHeadPic dreher.adam
2017-05-26 06:40:02 Hello,
Any update on getting this to work? I have the same setup.
userHeadPic dreher.adam
2017-04-21 06:33:49 Hi Alawrence,

Sorry I can't help you, I got the same issue here....
My 10.1 inch board is a different one from WaveShare but doesn't work on Win10 either. On Win7 it's OK.
Although the screen electronics and touch electronics are a single board, their circuits are completely separated.
So if you have issues with the touch part only, the trouble maker is related to that part.

The VID of the USB is 0EEF which looks like eGalax is the brand. I installed their latest driver tool but without success..
The PID is 0005 but this could not be found on the web.

Perhaps you can use this info and please give us an update if you find something.
For the time being, I'm a bit disappointed in the WaveShare product because of this.

All the best,
userHeadPic vipje
2017-03-28 02:35:57 I downloaded and ran EventGhost on both my LattePanda and my laptop. When I plug in and remove the RTD2660H-based driver board from my laptop I get:

System.DeviceAttached [u'\\\\?\\DISPLAY#HYS4859#4&1177c581&0&UID50729728#{e6f07b5f-ee97-4a90-b076-33f57bf4eaa7}']
System.DeviceRemoved [u'\\\\?\\DISPLAY#HYS4859#4&1177c581&0&UID50729728#{e6f07b5f-ee97-4a90-b076-33f57bf4eaa7}']

When I do it on the LattePanda I get nothing.

I tried adjusting BIOS settings in case the on-board display was conflicting with this touchscreen. I disabled the Force Lid Open and changed the video port to HDMI rather than Auto. Still no luck. What's notable is that with the Force Lid Open set to Off the LattePanda won't boot with the touchscreen plugged in. If I plug in my full-fledged Dell monitor I can boot to BIOS and if I switch the HDMI cable over to the touchscreen at that point I can view BIOS fine. Once I go to boot Windows the touchscreen will lose signal.

Any ideas? Could it be an HDMI version compliance compatibility issue? Is the RTD2660H chip only partially compliant to standards? I realize that the touchscreen may be at fault and there may be no issue with the LattePanda.
userHeadPic alawrence
2017-03-27 22:51:29 I disassembled the screen a bit and found that it uses this driver board:

Has anyone gotten one of these to work with a LattePanda running the provided 32-bit windows 10?
userHeadPic alawrence
2017-03-25 06:57:46 Anything I can do to troubleshoot this? userHeadPic alawrence